Failed in lauching multiplayer mode

Feedback and support for the iOS (iPad/iPhone/iPod Touch) versions of Osmos
weiyc
Posts: 2
Joined: Fri Feb 15, 2013 7:53 am

Failed in lauching multiplayer mode

Postby weiyc » Fri Feb 15, 2013 8:09 am

Hi Osmos,
It is a nice game, wonderful BGM and amazing design.
But I get a problem here. I enter the Osmos, choose the multiplayer mode, then Game center, I successfully matched a player. Osmos works just perfect by now. However, once it finished matching the player and game center disappears, my screen goes black, at the next second it returns to the home page. It seems that Osmos crashes and I dont know why.

My device is iPhone 4 with iOS 6.1(10B144). BTW, I have tried some other games that have multiplayer mode, they just work well. So I suppose it is not the setting of my iPhone and gamecenter that causes this problem. I also try reboot, it doesnt help. Osmos works well when I chosse the single mode.
Nice game again, it would be better if you can help me solve this problem.

Thanks
weiyc

User avatar
eddybox
Site Admin
Posts: 638
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Failed in lauching multiplayer mode

Postby eddybox » Fri Feb 15, 2013 9:29 am

Hi weiyc,

Thanks for the info! This is the first we hear about a crash at that point in the game. We'd like to get to the bottom of it...

Could you send us your Osmos.log file please? Here's how:
1) Connect your iOS device to your computer.
2) In iTunes (on your computer), select your device (on the left, under 'Devices).
3) Go to the 'Apps' tab for your device, and scroll down to 'File Sharing'
4) Select 'Osmos', and on the right you should see some filenames appear.
5) Select 'Osmos.log' and hit the 'Save to...' button to save it to your computer.
6) Attach the log file to an email, sending it to <webmaster at hemispheregames dot com>

Thanks!!
Eddy

weiyc
Posts: 2
Joined: Fri Feb 15, 2013 7:53 am

Re: Failed in lauching multiplayer mode

Postby weiyc » Fri Feb 15, 2013 7:12 pm

Hi Eddy,

I have emailed the log file to you. Check if you can solve this problem.

Thanks
weiyc

User avatar
eddybox
Site Admin
Posts: 638
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Failed in lauching multiplayer mode

Postby eddybox » Sun Feb 17, 2013 7:45 pm

Just wanted to follow up here so others will benefit from our troubleshooting...

It looks like Osmos was crashing due to Chinese characters in weiyc's Game Center alias. Obviously Osmos shouldn't crash in those circumstances, and we'll try to fix this in our next update. But in the meantime, if you'd like to play Osmos multiplayer over Game Center and this is affecting you, please change your alias. Sorry about the inconvenience!

Eddy

User avatar
Meal Worms
Posts: 624
Joined: Wed Apr 22, 2009 12:22 pm
Location: Toronto, Ontario, Canada
Contact:

Re: Failed in lauching multiplayer mode

Postby Meal Worms » Fri May 03, 2013 9:46 am

Hey all,

I'm happy to report we've got an update coming for Osmos very soon that includes a full translation to Chinese! Look for the update in the coming weeks!

Cheers all,
Dave


Return to “iOS Osmos (iPad/iPhone/iPod Touch)”

Who is online

Users browsing this forum: No registered users and 1 guest