Can't start game: "Incorrect Architecture"

Feedback and support for the Android versions of Osmos
BlueAchenar
Posts: 2
Joined: Sun Jun 05, 2016 9:39 am

Can't start game: "Incorrect Architecture"

Postby BlueAchenar » Sun Jun 05, 2016 9:44 am

Hello,

I recently upgraded my phone to a new one. Now when I try to run Osmos HD I get the message:

"Unable to find an appropriate native library architecture for this device. Expected [armeabi] but only [, arm64-v8a] are supported on this device"

It's the only app I have problems with so far. Any solutions?

Thanks

User avatar
eddybox
Site Admin
Posts: 636
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Can't start game: "Incorrect Architecture"

Postby eddybox » Sun Jun 05, 2016 9:23 pm

Hi BlueAchenar,

Yikes, that's a new one! What phone do you have? (Brand, model, etc.) Also, what OS version are you running?

Thanks,
Eddy

BlueAchenar
Posts: 2
Joined: Sun Jun 05, 2016 9:39 am

Re: Can't start game: "Incorrect Architecture"

Postby BlueAchenar » Mon Jun 06, 2016 2:40 am

It is a Zopo Speed 7 (ZP951) with a Mediatek MT6753 CPU, running Android 6.0.

xedex
Posts: 1
Joined: Sun Jul 10, 2016 9:05 am

Re: Can't start game: "Incorrect Architecture"

Postby xedex » Sun Jul 10, 2016 9:12 am

I am having the same issue with an Asus ZenPad 10 running Marshmallow.
Model number P00C
Android Version: 6.0
Android security patch level
June 1, 2016

Kernel version
3.18.22
android@mec11 #1
Fri May 27 15:55:44 CST 2016

Build number NRA58K.WW_P00C-V4.01-20160527
060010743_201603300140

The complete error message is
Incorrect Achitecture (the mis-spelling is in the error message)

Unable to find an appropriate native library architecture for this device. Expected [armeabi] but only [, arm64-v8a] are supported on this device.

I hope you guys will have a fix for this!


Thanks,

Michael

User avatar
eddybox
Site Admin
Posts: 636
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Can't start game: "Incorrect Architecture"

Postby eddybox » Sat Aug 20, 2016 1:22 pm

Hi BlueAchenar, xedex,

Sorry about the problems and thanks for the info. Please send us an email at webmaster@hemispheregames.com and we'll send you a different version which may (hopefully!) fix the problem.

Thanks,
Eddy


Return to “Android Osmos”

Who is online

Users browsing this forum: No registered users and 1 guest