Linux Support

Feedback and support for the PC version of Osmos
User avatar
Meal Worms
Posts: 624
Joined: Wed Apr 22, 2009 12:22 pm
Location: Toronto, Ontario, Canada
Contact:

Re: Linux Support

Postby Meal Worms » Thu Mar 31, 2011 4:17 am

I hear you ekolguy. Well, I'm not sure there's much we can do. Can you raise the issue with the Ubuntu platform folks? Osmos on Linux is vanilla OpenGL, and given that the game runs fine on your box with earlier versions of Ubuntu, my inclination is to suspect a bug in the updated graphics drivers.

Thanks,
Dave

Batmanifestdestiny
Posts: 1
Joined: Sat Jul 09, 2011 10:33 am

Re: Linux Support

Postby Batmanifestdestiny » Sat Jul 09, 2011 10:45 am

First of all, I feel inclined to say that Osmos is one of the best "atmospheric" games I've ever played. It's a real sit-back-and-absorb-stuff-on-a-Sunday-afternoon game.


However, I did encounter a problem that was kind of frustrating. I downloaded the tarball and it extracted just fine, but when I would try to run it I would get:
./Osmos: line 15: 3487 Segmentation fault $BIN $@


After some frustration, I found that by running it as root ("sudo Osmos" as opposed to "Osmos") made it run just fine. I'm not sure if this is a widespread problem or if I just accidentally put some dependencies in chroot jail or what, but I figured I would post my problem and the solution here. Is this a problem that lots of people have?

specs:
distro: Zenwalk 7.0 Openbox Edition (32 bit)
window manager: dwm
filesystem: ext4
graphics card: NVIDIA GeForce 8600
RAM: 2 GB DDR2
Processor: 2.2 GHz AMD (if I remember correctly)


I installed Osmos once before, but I can't remember if I had to run it as root and I later repartitioned my hard drive, effectively wiping my /home partition.

Personally, I see no problem in running the program as root, I was just thinking that new users are generally told to avoid root like the plague, so they might not think of this as a solution.

User avatar
Meal Worms
Posts: 624
Joined: Wed Apr 22, 2009 12:22 pm
Location: Toronto, Ontario, Canada
Contact:

Re: Linux Support

Postby Meal Worms » Tue Jul 12, 2011 7:04 am

Hi there,

This is the first we've heard of this problem; it must be something specific to your config. I'm afraid I'm not enough of a Linux guru to know what the issue might be; anyone else here in the Linux forum with advice to share?

Dave

Dazdnconfused
Posts: 5
Joined: Mon Aug 08, 2011 4:30 pm

Re: Linux Support - OpenAL or other sound issue?

Postby Dazdnconfused » Mon Aug 08, 2011 4:54 pm

Installed a few days ago and visuals seems to work fine, but no sound. The FAQ page indicated OpenAL was required. The download page only had source available for Linux. After 4 hours, I think I finally have OpenAL compiled and installed, but still no sound. Tried -1,0 and 1 for "soundDevice" both before and after OpenAL install, but still no sound. No log is ever generated, so I can't check that. Any suggestions? (assume n00b level...many of the questions and replies on this thread have flown over my head)
Running Ubuntu 10.04 with AC'97 Audio Controller sound and NV41.8 [GeForce Go 6800] display
thanks

User avatar
Meal Worms
Posts: 624
Joined: Wed Apr 22, 2009 12:22 pm
Location: Toronto, Ontario, Canada
Contact:

Re: Linux Support

Postby Meal Worms » Tue Aug 09, 2011 4:52 am

Hi Dazdnconfused,

If no log file is being generated, am I correct in assuming the game is crashing at startup? If so, try launching the game from a terminal, so that log output gets echoed to the terminal window as well. What text appears in the terminal as you're running Osmos?

Regarding OpenAL, you shouldn't have to compile it from scratch. Rather, Ubuntu has a 'package manager' you can use to download the latest version of OpenAL for your machine.

Regardless though: when you install Osmos, it should automatically download any libraries it needs that you don't already have, including OpenAL. Can you describe how exactly you went about installing Osmos on your box?

Thanks,
Dave

Dazdnconfused
Posts: 5
Joined: Mon Aug 08, 2011 4:30 pm

Re: Linux Support - OpenAL

Postby Dazdnconfused » Tue Aug 09, 2011 1:33 pm

It does not bomb - it seems to work fine apart from the sound. I suck at it, but that it another issue. You're right, I had not noticed the terminal echoes a log, but does not write one as a file. What I got just now -
===

Code: Select all

Log opened on Tue Aug  9 17:05:50 2011
Commandline: ./Osmos.bin32
Preinitializing game: HEMI version 1.6.1 1568
Localization: using language "en"
Localization: loaded Osmos-en.loc
Arch: Intel(R) Pentium(R) M processor 1.73GHz
OS: Linux 2.6.32-25-generic (#45-Ubuntu SMP Sat Oct 16 19:48:22 UTC 2010)
Using sound
Showing splash
Using fullscreen mode: 1440 x 900
Not using vsync
Initializing GLRenderDevice...
OpenGL version: 2.1.2 NVIDIA 195.36.24
Initializing game
Initializing GLRenderer...
Loading textures
Loading fonts
Backed up stats to Stats/Backup/Osmos_0015.sta
Initializing SoundSystem...
Initializing OpenAL
Getting OpenAL device list
Found 4 devices:
  Device 0: PulseAudio Software (3: OPENAL DEFAULT)
  Device 1: ALSA Software
  Device 2: OSS Software (2: OSMOS DEFAULT)
  Device 3: PortAudio Software
Pass 1: no valid device was specified (-1)
Pass 2: attempting device 2: "OSS Software"...
Creating OpenAL context
Opened device "OSS Software"
Device supports maximum 256 sources
Streaming music
Loading pre-splash sounds
Loading post-splash sounds

==========
There was no listing for OpenAL in Synaptic Package Manager. There is one now because I built it with Checkinstall after the compile with CMAKE and MAKE. I could not see any way to "install" Osmos itself and found no instructions on how that should occur, so I just run the shell script in terminal with

Code: Select all

./Osmos

The file I experimented with to get Osmos to run on each device option was defaults.cfg. I am not clear which, if any, of these four recognized OpenAL devices refers to my standard output, which is usually a Creative Xmod 4.1 unit, but I can switch back to the default, just listed within the system as "internal audio analog stereo". Neither works, though, regardless of the value in "soundDevice"

User avatar
Meal Worms
Posts: 624
Joined: Wed Apr 22, 2009 12:22 pm
Location: Toronto, Ontario, Canada
Contact:

Re: Linux Support

Postby Meal Worms » Wed Aug 10, 2011 7:36 am

Hi Dazdnconfused,

Okay, OpenAL is installed correctly, as evidenced by the contents of your log file. If you've tried each of the devices listed in the sound device list and none are working, there must be a problem with your sound config. To be clear, though: have you tried configuring Osmos to use a difference sound device, as described in the Osmos FAQ?

Dave

Dazdnconfused
Posts: 5
Joined: Mon Aug 08, 2011 4:30 pm

Re: Linux Support

Postby Dazdnconfused » Thu Aug 11, 2011 2:13 pm

As I wrote, I tried what the FAQ suggested in the only file I have that references "soundDevice", which is default.cfg in the main Osmos folder expanded from the .gz file. It does not affect the sound. ~/.Osmos/Config.cfg) does not exist. It really looks like there are some basic installation steps I still need to go through, but I have found no info on how to do that. Can you point me at a page that can walk me through the Osmos install?

User avatar
Meal Worms
Posts: 624
Joined: Wed Apr 22, 2009 12:22 pm
Location: Toronto, Ontario, Canada
Contact:

Re: Linux Support

Postby Meal Worms » Mon Aug 15, 2011 10:20 am

Hi Dazdnconfused,

There's no sophisticated Osmos install process; Osmos is distributed in binary form, and simply opening it with your package manager is all you need to do (or simply unpacking the .tar.gz) should be sufficient.

Regarding the 'soundDevice' mojo, you mentioned you've tried 0, 1, and -1, but the reason why I asked is because in the Osmos log contents you posted, there were listed other sound devices which you didn't mentioned having tried, e.g. PortAudio.

Not sure why you're having trouble, the game should just work 'out of the box'. You've been using the .tar.gz; can you try using one of the other package file formats instead, which will verify dependencies for you when you open it in a package manager?

Thanks,
Dave

Dazdnconfused
Posts: 5
Joined: Mon Aug 08, 2011 4:30 pm

Re: Linux Support

Postby Dazdnconfused » Mon Aug 15, 2011 1:35 pm

Installed from .deb via package manager this time - file structure very different. I am getting a log and a Config.cfg in the home/.Osmos dir now. No sound difference though. OpenAL now only lists two audio possibilities. Here is the log running with option 1, then option 0. Do you see anything off here?

Code: Select all

----------------------------------------------------------------------------------------------------
Log opened on Mon Aug 15 17:21:17 2011
Commandline: ./Osmos.bin32
Preinitializing game: HEMI version 1.6.1 1568
Localization: using language "en"
Localization: loaded Osmos-en.loc
Arch: Intel(R) Pentium(R) M processor 1.73GHz
OS: Linux 2.6.32-25-generic (#45-Ubuntu SMP Sat Oct 16 19:48:22 UTC 2010)
Using sound
Showing splash
Using fullscreen mode: 1440 x 900
Not using vsync
Initializing GLRenderDevice...
OpenGL version: 2.1.2 NVIDIA 195.36.24
Initializing game
Initializing GLRenderer...
Loading textures
Loading fonts
Backed up stats to Stats/Backup/Osmos_0026.sta
Initializing SoundSystem...
Initializing OpenAL
Getting OpenAL device list
Found 2 devices:
  Device 0: OSS Default (3: OPENAL DEFAULT)
  Device 1: No Output (1: USER-SPECIFIED)
Pass 1: attempting device 1: "No Output"...
Creating OpenAL context
Opened device "No Output"
Device supports maximum 256 sources
Streaming music
Loading pre-splash sounds
Loading post-splash sounds
App exiting -- bye!
Writing config to Config.cfg
Deinitializing SoundSystem
Log closed on Mon Aug 15 17:22:10 2011
----------------------------------------------------------------------------------------------------
----------------------------------------------------------------------------------------------------
Log opened on Mon Aug 15 17:23:54 2011
Commandline: ./Osmos.bin32
Preinitializing game: HEMI version 1.6.1 1568
Localization: using language "en"
Localization: loaded Osmos-en.loc
Arch: Intel(R) Pentium(R) M processor 1.73GHz
OS: Linux 2.6.32-25-generic (#45-Ubuntu SMP Sat Oct 16 19:48:22 UTC 2010)
Using sound
Showing splash
Using fullscreen mode: 1440 x 900
Not using vsync
Initializing GLRenderDevice...
OpenGL version: 2.1.2 NVIDIA 195.36.24
Initializing game
Initializing GLRenderer...
Loading textures
Loading fonts
Backed up stats to Stats/Backup/Osmos_0027.sta
Initializing SoundSystem...
Initializing OpenAL
Getting OpenAL device list
Found 2 devices:
  Device 0: OSS Default (1: USER-SPECIFIED) (3: OPENAL DEFAULT)
  Device 1: No Output
Pass 1: attempting device 0: "OSS Default"...
Creating OpenAL context
Opened device "OSS Default"
Device supports maximum 256 sources
Streaming music
Loading pre-splash sounds
Loading post-splash sounds
App exiting -- bye!
Writing config to Config.cfg
Deinitializing SoundSystem
Log closed on Mon Aug 15 17:24:35 2011
----------------------------------------------------------------------------------------------------


Return to “Osmos PC (Win/Mac/Linux)”

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest