Linux Support

Feedback and support for the PC version of Osmos
moofang
Posts: 1
Joined: Tue Feb 21, 2012 11:51 pm

Re: Linux Support

Postby moofang » Wed Feb 22, 2012 12:06 am

Hello, I've been trying out Osmos on linux and it looks pretty cool! I have a touch-screen tablet running linux and I've been experimenting with playing it there. Osmos for linux behaves like the desktop version there though so I've been devising workarounds to get around not having a keyboard. My question is: since Osmos has a nice touch interface for iPad/Android (or so I assume), might it be possible to activate this interface for a desktop version (specifically the linux one) too?

Also, the linux demo version is still at 1.6.0, and so no text displays at all on most contemporary distros. I was able to get around this by applying a workaround posted earlier in this thread, but it'd be great if the demo could be updated as well so someone less motivated/geeky than me wouldn't give up before actually getting to try the game out.

All the same, I'm extremely glad you have a native linux version! I promise to cough up if/when I'm confident that I can play this comfortably on my tablet :P Also please do consider updating the linux demos - it'll make it easier for me to recommend the game to other linux users too.

booxy
Posts: 1
Joined: Fri Aug 24, 2012 2:35 pm

Can't start Osmos in ubuntu Lucid 10.04

Postby booxy » Fri Aug 24, 2012 3:16 pm

Hello out there,

I just purchased, downloaded and installed the >Osmos_1.6.1.deb< onto my uberstudent 1.0 [https://www.facebook.com/pages/UberStudent-Linux/345518906926] distribution. It is an ubuntu derivate of Lucid Lynx 10.04. .
I tried to start Osmos by clicking its icon a several time: no reaction.

Here is the output of >Osmos.log<:
----------------------------------------------------------------------------------------------------
Log opened on Sat Aug 25 00:54:02 2012
Commandline: ./Osmos.bin32
Preinitializing game: HEMI version 1.6.1 1568
Localization: using language "de"
Localization: loaded Osmos-de.loc
Arch: AMD Athlon(tm) 5200 Dual-Core Processor
OS: Linux 2.6.32-41-generic (#94-Ubuntu SMP Fri Jul 6 16:51:39 UTC 2012)
Using sound
Showing splash
Log closed on Sat Aug 25 00:54:02 2012
-----------------------------------------------------------------------------------------------------

Does anybody know what might be the problem?

I thought: what a shit, bought a great game and now nothing is happening. So I tried to install the Windows version >OsmosInstaller_1.6.0.exe< with wine. I got it installed. but when i try to start Osmos, it asks if it should update automatically -I am clicking Yes- then it asks if it should use full screen -I am clicking Yes- and then it gives out an error:
"Error creating window"

So dear support, dear forumist@s
Can u help me?

Thanks in forward
booxy

User avatar
eddybox
Site Admin
Posts: 636
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Linux Support

Postby eddybox » Mon Aug 27, 2012 9:01 am

Hi booxy,

We got your email to webmaster -- replying now...

Thanks,
Eddy

User avatar
eddybox
Site Admin
Posts: 636
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Linux Support

Postby eddybox » Tue Jan 29, 2013 3:46 pm

Howdy folks,

We have a 1.6.1 demo ready (which fixes the font problem), but only in tarball format so far, as we're having a hard time building the .deb and .rpm packages. If anyone is interested in the tarball, or is willing to lend a hand with building those other distribution formats (for which we'd be much obliged!), check out this thread: viewtopic.php?f=8&t=554&p=3952&sid=1fe60e058938ed5418f64a9b2c02bdda#p3952

Cheers!
Eddy

zunh
Posts: 4
Joined: Mon Feb 18, 2013 6:47 am

Re: Linux Support

Postby zunh » Mon Feb 18, 2013 7:14 am

Hi,

I like the music but I hear an irritating clicking echo. Is there a workaround for this?

Kind regards
zunh

Edit: Sample can be found here - http://soundcloud.com/zunh/clickingechoes

User avatar
eddybox
Site Admin
Posts: 636
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Linux Support

Postby eddybox » Mon Feb 18, 2013 11:02 am

Hi zunh,

First we hear that one! What OS are you running? Also, which version of Osmos are you running? (Look at the build number in the lower right corner of the credits screen.)

Thanks,
Eddy

zunh
Posts: 4
Joined: Mon Feb 18, 2013 6:47 am

Re: Linux Support

Postby zunh » Mon Feb 18, 2013 1:51 pm

Hi,

Thank you for your reply.

Osmos v1.6.1 build 2302

Kernel: 3.2.0-23-generic i686 (32 bit) Desktop: Xfce 4.10.0 Distro: Linux Mint 13 Maya
Creative Labs SB Live! EMU10k1 driver: snd_emu10k1 Sound: ALSA ver: 1.0.24
CPU: Dual core AMD Athlon 64 X2 5000+ (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 svm)
Clock Speeds: 1: 2600.876 MHz 2: 2600.876 MHz
Graphics: Card: NVIDIA GF110 [GeForce GTX 560 Ti] X.Org: 1.11.3 driver: nvidia Resolution: 1920x1200@60.0hz
GLX Renderer: GeForce GTX 560 Ti/PCIe/SSE2/3DNOW! GLX Version: 4.2.0 NVIDIA 304.64

The game works fine otherwise except some rare pauses but they are not as distracting as the constant ticking sounds.
All the other games I bought with Steam on Linux have worked except one that wouldn't install at all and one that won't let me choose where to install the game.

Cheers
zunh

User avatar
eddybox
Site Admin
Posts: 636
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Linux Support

Postby eddybox » Mon Feb 18, 2013 2:34 pm

Thanks for the info, zunh.

Could you give the demo a try please and let us know if it clicks as well? http://www.hemispheregames.com/osmos/#anchor_demos

Perhaps this is only an issue with the new Steam build...

Thanks,
Eddy

zunh
Posts: 4
Joined: Mon Feb 18, 2013 6:47 am

Re: Linux Support

Postby zunh » Mon Feb 18, 2013 2:59 pm

The demo has the same clicking echoes for me. I also didn't see any text (for example in the menu). The ogg files played fine in vlc.

Edit: I have discovered more games that has clicking sound now. Out of 15 games I have this problem in six of them; Osmos, Dwarfs, Trine 2, The Book of Unwritten Tales, Anomaly Warzone Earth, Frozen Synapse.

User avatar
eddybox
Site Admin
Posts: 636
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Linux Support

Postby eddybox » Tue Feb 19, 2013 10:52 am

Thanks for trying that out and the extra info, zunh.

Sounds like Linux Mint has some issues with their OpenAL library. (A pretty standard sound library.) It's probably worth pinging them to see if it's a known issue and if they're working on it. Feel free to point them our way if they'd like more info about our usage of OpenAL.

Thanks,
Eddy


Return to “Osmos PC (Win/Mac/Linux)”

Who is online

Users browsing this forum: No registered users and 1 guest