Mac Support

Feedback and support for the PC version of Osmos
User avatar
eddybox
Site Admin
Posts: 636
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Mac Support

Postby eddybox » Thu Dec 10, 2009 5:21 pm

The Mac version of Osmos is now available! :D

http://www.hemispheregames.com/2009/12/ ... s-release/

Please post to this thread if you have any technical issues or Mac-specific question/comments.

Thanks!
Eddy

felixturner
Posts: 5
Joined: Thu Dec 10, 2009 11:18 pm

Re: Mac Support

Postby felixturner » Thu Dec 10, 2009 11:19 pm

Just played it. works great! lovely game...

chronos
Posts: 1
Joined: Sun Dec 13, 2009 4:01 pm

Re: Mac Support

Postby chronos » Sun Dec 13, 2009 4:06 pm

Is there any way to change the keyboard shortcuts? I'm getting pretty frustrated with trying to play this on a Macbook Pro because it is too easy to gesture speeding up or slowing down time by accident when using the trackpad. It would be nice to change the shortcut to something else. Otherwise a brilliant game.

User avatar
eddybox
Site Admin
Posts: 636
Joined: Sat Dec 13, 2008 11:22 am
Location: Nelson, BC, Canada
Contact:

Re: Mac Support

Postby eddybox » Sun Dec 13, 2009 5:40 pm

Hi chronos,

There is! Check out the explanation in our FAQ for starters: http://www.hemispheregames.com/faq-pcos ... eybindings
Let us know if you need additional pointers.

Cheers,
Eddy

lafnum
Posts: 2
Joined: Sat Jan 09, 2010 3:20 am

Re: Mac Support

Postby lafnum » Sat Jan 09, 2010 3:25 am

I have just purchased Osmos for the Mac. I am running the latest version of OSX, snow leopard, version 10.6.2. There is a problem with the sound. It is only a series of clicks. How can I correct this problem?

curmudgeonlybumbly
Posts: 51
Joined: Thu Jul 23, 2009 1:34 pm

Re: Mac Support

Postby curmudgeonlybumbly » Mon Jan 11, 2010 9:06 am

We haven't had any sound problems with 10.6.2, so the sound should "just work".
A few quick troubleshooting steps
    Try rebooting the machine just in case a previously crashed program left the audio system in a bad state.
    Check that the sound and speakers and volume are all correct on your machine by running another program that plays sounds (iTunes for example)
If this doesn't solve the problem, please post the contents of your osmos.log file located in home/Library/Application Support/Osmos to the message board, and I'll see if I can sort it out.

Aaron
Chief Mac Developer

lafnum
Posts: 2
Joined: Sat Jan 09, 2010 3:20 am

Re: Sound Problem

Postby lafnum » Wed Jan 13, 2010 3:04 am

Aaron:
Thank you for your reply.
I tried restarting my laptop with no success.
Audio in all other programs is working correctly.
Here are the contents of the osmos.log file.

Commandline: /Applications/Osmos.app/Contents/MacOS/Osmos -psn_0_2298417
Preinitializing game: HEMIMAC version 1.5.14 1174
Localization: using language "en"
Localization: loaded Osmos-en.loc
Machine: MacBook2,1
Processors: 2
Processor speed: 2000
OS: Version 10.6.2 (Build 10C540)
checking for version udpate
using sound
showing splash
Initializing game
Initializing GLRenderer...
Loading textures
Loading fonts
Propagating progress from demo...
Initializing SoundSystem...
Loading pre-splash sounds
Loading post-splash sounds
Initializing game
Initializing GLRenderer...
Initializing game
Initializing GLRenderer...
Writing config to Config.cfg
Deinitializing SoundSystem
Commandline: /Applications/Osmos.app/Contents/MacOS/Osmos -psn_0_2372163
Preinitializing game: HEMIMAC version 1.5.14 1174
Localization: using language "en"
Localization: loaded Osmos-en.loc
Machine: MacBook2,1
Processors: 2
Processor speed: 2000
OS: Version 10.6.2 (Build 10C540)
checking for version udpate
using sound
showing splash
Initializing game
Initializing GLRenderer...
Loading textures
Loading fonts
Backed up stats to Stats/Backup/Osmos_Jan__9_2010_0000.sta
Initializing game
Initializing GLRenderer...
Initializing SoundSystem...
Loading pre-splash sounds
Loading post-splash sounds
Writing config to Config.cfg
Deinitializing SoundSystem
Commandline: /Applications/Osmos.app/Contents/MacOS/Osmos -psn_0_2441812
Preinitializing game: HEMIMAC version 1.5.14 1174
Localization: using language "en"
Localization: loaded Osmos-en.loc
Machine: MacBook2,1
Processors: 2
Processor speed: 2000
OS: Version 10.6.2 (Build 10C540)
checking for version udpate
using sound
showing splash
Initializing game
Initializing GLRenderer...
Loading textures
Loading fonts
Backed up stats to Stats/Backup/Osmos_Jan__9_2010_0001.sta
Initializing game
Initializing GLRenderer...
Initializing SoundSystem...
Loading pre-splash sounds
Loading post-splash sounds
Writing config to Config.cfg
Deinitializing SoundSystem
Commandline: /Applications/Osmos.app/Contents/MacOS/Osmos -psn_0_2511461
Preinitializing game: HEMIMAC version 1.5.14 1174
Localization: using language "en"
Localization: loaded Osmos-en.loc
Machine: MacBook2,1
Processors: 2
Processor speed: 2000
OS: Version 10.6.2 (Build 10C540)
checking for version udpate
using sound
showing splash
Initializing game
Initializing GLRenderer...
Loading textures
Loading fonts
Backed up stats to Stats/Backup/Osmos_Jan__9_2010_0002.sta
Initializing game
Initializing GLRenderer...
Initializing SoundSystem...
Loading pre-splash sounds
Loading post-splash sounds
Writing config to Config.cfg
Deinitializing SoundSystem
Commandline: /Applications/Osmos.app/Contents/MacOS/Osmos -psn_0_7571256
Preinitializing game: HEMIMAC version 1.5.14 1174
Localization: using language "en"
Localization: loaded Osmos-en.loc
Machine: MacBook2,1
Processors: 2
Processor speed: 2000
OS: Version 10.6.2 (Build 10C540)
checking for version udpate
using sound
showing splash
Initializing game
Initializing GLRenderer...
Loading textures
Loading fonts
Backed up stats to Stats/Backup/Osmos_Jan_12_2010_0000.sta
Initializing game
Initializing GLRenderer...
Initializing SoundSystem...
Loading pre-splash sounds
Loading post-splash sounds
Writing config to Config.cfg
Deinitializing SoundSystem
Commandline: /Applications/Osmos.app/Contents/MacOS/Osmos -psn_0_426088
Preinitializing game: HEMIMAC version 1.5.14 1174
Localization: using language "en"
Localization: loaded Osmos-en.loc
Machine: MacBook2,1
Processors: 2
Processor speed: 2000
OS: Version 10.6.2 (Build 10C540)
checking for version udpate
using sound
showing splash
Initializing game
Initializing GLRenderer...
Loading textures
Loading fonts
Backed up stats to Stats/Backup/Osmos_Jan_13_2010_0000.sta
Initializing game
Initializing GLRenderer...
Initializing SoundSystem...
Loading pre-splash sounds
Loading post-splash sounds
Writing config to Config.cfg
Deinitializing SoundSystem

curmudgeonlybumbly
Posts: 51
Joined: Thu Jul 23, 2009 1:34 pm

Re: Mac Support

Postby curmudgeonlybumbly » Fri Jan 15, 2010 8:36 am

Audio problems solved. Lafnum was running Hear by Prosoft Engineering, which attempts to enhance sounds across OS X. Unfortunately Hear and Osmos are not compatible. Please disable Hear while you are running Osmos.

davidestevens
Posts: 2
Joined: Wed Jan 20, 2010 3:38 pm

POV suddenly fixed!

Postby davidestevens » Wed Jan 20, 2010 3:42 pm

hi,

For some reason, when I started up Osmos today, the blob that is me remains in the middle of the screen instead of zooming around (the surrounding world does the zooming instead). I'm pretty sure it didn't used to do this, and I have no idea how I switched to this viewpoint (and I can't find a menus option for it either). How do I go back to the normal view?

thanks

David

User avatar
Meal Worms
Posts: 624
Joined: Wed Apr 22, 2009 12:22 pm
Location: Toronto, Ontario, Canada
Contact:

Re: Mac Support

Postby Meal Worms » Thu Jan 21, 2010 8:31 am

Hi davidestevens,

The usual behaviour for Osmos is for the screen to pan with the player locked at the centre. There are exceptions, though: for levels that are smaller, or when your view is fully zoomed out, there's no need to pan because the player can see the entire level.

Dave


Return to “Osmos PC (Win/Mac/Linux)”

Who is online

Users browsing this forum: No registered users and 2 guests